Xanda's Blog !~!

Khweeteur (on Maemo) Segmentation Fault Workaround

Aug
12

For those who are on N900 (Maemo) and having problem in launching or installing [1] Khweeteur v0.5* this is the workaround for the problem

[1] Error in installing means: if you found the following error during installation :

Listing /usr/lib/python2.5/site-packages/khweeteur ...
Listing /usr/lib/python2.5/site-packages/khweeteur/icons ...
Listing /usr/lib/python2.5/site-packages/khweeteur/oauth ...
Listing /usr/lib/python2.5/site-packages/khweeteur/oauth2 ...
Segmentation fault
Segmentation fault
dpkg: error processing khweeteur (--configure):

So here is the temporary workaround for this problem

1) Install older version of python-pyside

sudo apt-get install libpyside1.0=1.0.3-1maemo2 python-pyside=1.0.3-1maemo2 libshiboken1.0=1.0.3-1maemo1 python-pyside.phonon=1.0.3-1maemo2 python-pyside.qtcore=1.0.3-1maemo2 python-pyside.qtgui=1.0.3-1maemo2 python-pyside.qtdeclarative=1.0.3-1maemo2 python-pyside.qtmaemo5=1.0.3-1maemo2 python-pyside.qtmultimedia=1.0.3-1maemo2 python-pyside.qtnetwork=1.0.3-1maemo2 python-pyside.qtopengl=1.0.3-1maemo2 python-pyside.qtscript=1.0.3-1maemo2 python-pyside.qtsql=1.0.3-1maemo2 python-pyside.qtsvg=1.0.3-1maemo2 python-pyside.qtwebkit=1.0.3-1maemo2 python-pyside.qtxml=1.0.3-1maemo2 python-pyside.qtxmlpatterns=1.0.3-1maemo2

2) Install pyside-mobility

sudo apt-get install pyside-mobility

3) Now install you khweeteur or khweeteur-experimental

sudo apt-get install khweeteur-experimental

P/S: Do not update your pyside to the latest version until khweeteur has change the code to suite the latest pyside accordingly.

Leave a Reply

Your email address will not be published. Required fields are marked *